Project

General

Profile

Создание набросков пользовательского интерфейса с помощью Pencil

Очень важным этапом при создании приложения для конечных пользователей является пользовательский интерфейс. А при проектировании интерфейса важно уметь его быстро изменять согласно последним выдумкам заказчика/руководства/здравого смысла. Для людей, не умеющих держать карандаш/ручку в руке были созданы специализированные инструменты, которые позволяют упростить и облегчить процесс создания набросков.

Данное руководство рассказывает об установке и настройке инструмента Pencil

Установка в качестве дополнения к браузеру Firefox

Данный подход следует использовать в том случае, если вы хотите посмотреть на функциональность приложения, но не хотите устанавливать его как отдельное приложение. Для некоторых платформ не поставляется последняя версия Pencil в качестве отдельного приложения, поэтому для таких платформ это единственный вариант.

  1. Установите браузер Firefox последней версии.

  2. Скачайте дополнение к браузеру, со страницы загрузок

  3. Если установка дополнения не началась автоматически, откройте скачанный файл в FireFox, выбрав пункт меню Файл->Открыть.

  4. По окончании установки перезагрузите браузер.

  5. Запустите Pencil, выбрав пункт меню Инструменты->Pencil

Установка Pencil как отдельное приложение

Для части платформ Pencil поставляется как отдельное приложение. Для его установки скачайте установочный пакет для своей операционной системы со страницы загрузок Запустите скачанный файл, следуйте указаниям мастера установки, чтобы завершить установку.

Установка расширений

Pencil позволяет сторонним разработчикам создавать свои наборы элементов и делиться этими наборами друг с другом. Для установки дополнительного набора компонент следуйте инструкции:

  1. Зайдите на страницу расширений

  2. Выберите нужное расширение, скачайте ZIP архив данного расширения и сохраните его на диске.

  3. Запустите Pencil.

  4. Выберите пункт меню Pencil->Tools->Install new collection.

  5. В появившемся окне выберите сохранённый ZIP архив.

  6. Если архив не подписан разработчиком, то Pencil попросит подтвердить решение на установку данного дополнения.

Если вы сделали всё верно, то у вас должен появится ещё один дополнительный набор элементов.